CM3D2 Toolkit

CM3D2 Toolkit Help File
CM3D2 Toolkit

[This is preliminary documentation and is subject to change.]

Namespaces
Namespace | Description
CM3D2.Toolkit | The CM3D2.Toolkit is the Root namespace
CM3D2.Toolkit.Arc | The CM3D2.Toolkit.Arc namespace contains all the classes for Handling of KISS's .arc Files
CM3D2.Toolkit.Arc.Entry | The CM3D2.Toolkit.Arc.Entry namespace contains classes for holding the File and Directory Entries on a ArcFileSystem
CM3D2.Toolkit.Arc.FilePointer | The CM3D2.Toolkit.Arc.FilePointer namespace contains classes for holding Pointers and File Data on a ArcFileSystem
CM3D2.Toolkit.Logging | The CM3D2.Toolkit.Logging namespace contains classes for receiving Log Messages from the Library

Copyright (C) 2015 - Usagirei


CM3D2.Toolkit Namespace

CM3D2.Toolkit Namespace

The CM3D2.Toolkit is the Root namespace
Classes
 | Class | Description
Public class | Deflate | Contains Methods to Compress and Decompress data in the DEFLATE Specification See RFC 1951


Deflate Class

Deflate Class

Contains Methods to Compress and Decompress data in the DEFLATE Specification

See RFC 1951

Inheritance Hierarchy
SystemObject
CM3D2.ToolkitDeflate

Namespace: CM3D2.Toolkit
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static class Deflate

The Deflate type exposes the following members.

Methods
Name | Description
Compress | Compresses Data
Decompress | Decompresses Data
Top
See Also

Reference

CM3D2.Toolkit Namespace


Deflate Methods

Deflate Methods

The Deflate type exposes the following members.

Methods
Name | Description
Compress | Compresses Data
Decompress | Decompresses Data
Top
See Also

Reference

Deflate Class
CM3D2.Toolkit Namespace


Deflate.Compress Method

DeflateCompress Method

Compresses Data

Namespace: CM3D2.Toolkit
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Compress(
    byte[] input
)

Parameters

input
Type: SystemByte
Data to be Compressed

Return Value

Type: Byte
Compressed Data
See Also

Reference

Deflate Class
CM3D2.Toolkit Namespace


Deflate.Decompress Method

DeflateDecompress Method

Decompresses Data

Namespace: CM3D2.Toolkit
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static byte[] Decompress(
    byte[] input
)

Parameters

input
Type: SystemByte
Data to be Decompressed

Return Value

Type: Byte
Decompressed Data
See Also

Reference

Deflate Class
CM3D2.Toolkit Namespace


CM3D2.Toolkit.Arc Namespace

CM3D2.Toolkit.Arc Namespace

The CM3D2.Toolkit.Arc namespace contains all the classes for Handling of KISS's .arc Files
Classes
 | Class | Description
Public class | ArcFileSystem | Arc File System Class Provides Methods and Functions to Handle Loading, Creating, Modifying and Saving of KISS's CM3D2 .arc Files


ArcFileSystem Class

ArcFileSystem Class

Arc File System Class

Provides Methods and Functions to Handle Loading, Creating, Modifying and Saving of KISS's CM3D2 .arc Files

Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.ArcArcFileSystem

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class ArcFileSystem

The ArcFileSystem type exposes the following members.

Constructors
 | Name | Description
Public method | ArcFileSystem | Creates a new Empty Instance of an Arc File System
Public method | ArcFileSystem(String) | Creates a new Empty Instance of an Arc File System named name
Top
Properties
 | Name | Description
Public property | CompressList | List of Extensions that will be Compressed upon saving
Public property | Directories | Listing of all Directories
Public property | Files | Listing of all Files
Public property | Logger | Instance Logger (Defaults to Instance)
Public property | Name | Internal Name of this .arc path
Public property | Root | File System Root
Top
Methods
 | Name | Description
 | CleanFileName | Removes invalid characters from the given File Name See GetInvalidFileNameChars
Public method | Clear | Clears the Root Directory
Public method | Clear(ArcDirectoryEntry) | Clears a Directory
Public method | Copy(ArcDirectoryEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Public method | Copy(ArcFileEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Public method | CreateDirectory(String) | Creates a Directory with the specified name inside Root
Public method | CreateDirectory(String, ArcDirectoryEntry) | Creates a Directory with the specified name inside parent
Public method | CreateFile(String) | Creates a File with the specified name inside Root
Public method | CreateFile(String, ArcDirectoryEntry) | Creates a File with the specified name inside parent
Public method | Delete(ArcFileEntry) | Deletes a File
Public method | Delete(ArcDirectoryEntry, Boolean) | Deletes a Directory
 | DetectMagic | Detects if the ARC Magic Identifier is present the specified file
Public method | DirectoryExists(String) | Checks if a Directory Exists inside of Root
Public method | DirectoryExists(String, ArcDirectoryEntry) | Checks if a Directory Exists inside of parent
Public method | FileExists(String) | Checks if a File Exists inside of Root
Public method | FileExists(String, ArcDirectoryEntry) | Checks if a File Exists inside of parent
Public method | GetDirectory(String) | Finds a Existing Directory inside Root
Public method | GetDirectory(String, ArcDirectoryEntry) | Finds a Existing Directory inside parent
Public method | GetFile(String) | Finds a Existing File inside Root
Public method | GetFile(String, ArcDirectoryEntry) | Finds a Existing File inside parent
Public method | HasEntry | Checks if an Arc Entry is part of this File System
Public method | LoadArc(String) | Loads an Arc File into Root
Public method | LoadArc(String, ArcDirectoryEntry) | Loads an Arc File in this Instance into parentDir
Public method | LoadDirectory(String) | Loads a Directory and its all files recursively into Root
Public method | LoadDirectory(String, ArcDirectoryEntry) | Loads a Directory and all its files recursively into parentDir
Public method | LoadFile(String) | Loads a Single File into Root
Public method | LoadFile(String, ArcDirectoryEntry) | Loads a Single File into parentDir
Public method | MergeCopy | Merges a Copy of sourceDir with targetDir
Public method | MergeMove | Merges sourceDir with targetDir
Public method | Move(ArcDirectoryEntry, ArcDirectoryEntry) | Moves into targetDir
Public method | Move(ArcFileEntry, ArcDirectoryEntry) | Moves into targetDir
Public method | Rename | Renames a ArcEntryBase
Public method | Save | Writes this File System instance to the Stream given by stream
Top
See Also

Reference

CM3D2.Toolkit.Arc Namespace


ArcFileSystem Constructor

ArcFileSystem Constructor

Overload List
 | Name | Description
Public method | ArcFileSystem | Creates a new Empty Instance of an Arc File System
Public method | ArcFileSystem(String) | Creates a new Empty Instance of an Arc File System named name
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem Constructor

ArcFileSystem Constructor

Creates a new Empty Instance of an Arc File System

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileSystem()
See Also

Reference

ArcFileSystem Class
ArcFileSystem Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem Constructor (String)

ArcFileSystem Constructor (String)

[This is preliminary documentation and is subject to change.]

Creates a new Empty Instance of an Arc File System named name

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileSystem(
    string name
)

Parameters

name
Type: SystemString
File System Name
See Also

Reference

ArcFileSystem Class
ArcFileSystem Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem Properties

ArcFileSystem Properties

The ArcFileSystem type exposes the following members.

Properties
 | Name | Description
Public property | CompressList | List of Extensions that will be Compressed upon saving
Public property | Directories | Listing of all Directories
Public property | Files | Listing of all Files
Public property | Logger | Instance Logger (Defaults to Instance)
Public property | Name | Internal Name of this .arc path
Public property | Root | File System Root
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CompressList Property

ArcFileSystemCompressList Property

List of Extensions that will be Compressed upon saving

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<string> CompressList { get; }

Property Value

Type: List String
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Directories Property

ArcFileSystemDirectories Property

Listing of all Directories

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IEnumerable<ArcDirectoryEntry> Directories { get; }

Property Value

Type: IEnumerable ArcDirectoryEntry
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Files Property

ArcFileSystemFiles Property

Listing of all Files

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IEnumerable<ArcFileEntry> Files { get; }

Property Value

Type: IEnumerable ArcFileEntry
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Logger Property

ArcFileSystemLogger Property

Instance Logger (Defaults to Instance)

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ILogger Logger { get; set; }

Property Value

Type: ILogger
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Name Property

ArcFileSystemName Property

Internal Name of this .arc path

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Root Property

ArcFileSystemRoot Property

File System Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcDirectoryEntry Root { get; }

Property Value

Type: ArcDirectoryEntry
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem Methods

ArcFileSystem Methods

The ArcFileSystem type exposes the following members.

Methods
 | Name | Description
 | CleanFileName | Removes invalid characters from the given File Name See GetInvalidFileNameChars
Public method | Clear | Clears the Root Directory
Public method | Clear(ArcDirectoryEntry) | Clears a Directory
Public method | Copy(ArcDirectoryEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Public method | Copy(ArcFileEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Public method | CreateDirectory(String) | Creates a Directory with the specified name inside Root
Public method | CreateDirectory(String, ArcDirectoryEntry) | Creates a Directory with the specified name inside parent
Public method | CreateFile(String) | Creates a File with the specified name inside Root
Public method | CreateFile(String, ArcDirectoryEntry) | Creates a File with the specified name inside parent
Public method | Delete(ArcFileEntry) | Deletes a File
Public method | Delete(ArcDirectoryEntry, Boolean) | Deletes a Directory
 | DetectMagic | Detects if the ARC Magic Identifier is present the specified file
Public method | DirectoryExists(String) | Checks if a Directory Exists inside of Root
Public method | DirectoryExists(String, ArcDirectoryEntry) | Checks if a Directory Exists inside of parent
Public method | FileExists(String) | Checks if a File Exists inside of Root
Public method | FileExists(String, ArcDirectoryEntry) | Checks if a File Exists inside of parent
Public method | GetDirectory(String) | Finds a Existing Directory inside Root
Public method | GetDirectory(String, ArcDirectoryEntry) | Finds a Existing Directory inside parent
Public method | GetFile(String) | Finds a Existing File inside Root
Public method | GetFile(String, ArcDirectoryEntry) | Finds a Existing File inside parent
Public method | HasEntry | Checks if an Arc Entry is part of this File System
Public method | LoadArc(String) | Loads an Arc File into Root
Public method | LoadArc(String, ArcDirectoryEntry) | Loads an Arc File in this Instance into parentDir
Public method | LoadDirectory(String) | Loads a Directory and its all files recursively into Root
Public method | LoadDirectory(String, ArcDirectoryEntry) | Loads a Directory and all its files recursively into parentDir
Public method | LoadFile(String) | Loads a Single File into Root
Public method | LoadFile(String, ArcDirectoryEntry) | Loads a Single File into parentDir
Public method | MergeCopy | Merges a Copy of sourceDir with targetDir
Public method | MergeMove | Merges sourceDir with targetDir
Public method | Move(ArcDirectoryEntry, ArcDirectoryEntry) | Moves into targetDir
Public method | Move(ArcFileEntry, ArcDirectoryEntry) | Moves into targetDir
Public method | Rename | Renames a ArcEntryBase
Public method | Save | Writes this File System instance to the Stream given by stream
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CleanFileName Method

ArcFileSystemCleanFileName Method

Removes invalid characters from the given File Name

See GetInvalidFileNameChars

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static string CleanFileName(
    string input
)

Parameters

input
Type: SystemString
File Name

Return Value

Type: String
File Name without invalid characters
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Clear Method

ArcFileSystemClear Method

Overload List
 | Name | Description
Public method | Clear | Clears the Root Directory
Public method | Clear(ArcDirectoryEntry) | Clears a Directory
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Clear Method

ArcFileSystemClear Method

Clears the Root Directory

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Clear()

Return Value

Type: Boolean
True if Sucessful
See Also

Reference

ArcFileSystem Class
Clear Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Clear Method (ArcDirectoryEntry)

ArcFileSystemClear Method (ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Clears a Directory

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Clear(
    ArcDirectoryEntry entry
)

Parameters

entry
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Directory to Clear

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Clear Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Copy Method

ArcFileSystemCopy Method

Overload List
 | Name | Description
Public method | Copy(ArcDirectoryEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Public method | Copy(ArcFileEntry, ArcDirectoryEntry) | Creates a copy of source inside target
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Copy Method (ArcDirectoryEntry, ArcDirectoryEntry)

ArcFileSystemCopy Method (ArcDirectoryEntry, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Creates a copy of source inside target

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Copy(
    ArcDirectoryEntry source,
    ArcDirectoryEntry target
)

Parameters

source
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Source Directory
target
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Copy Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Copy Method (ArcFileEntry, ArcDirectoryEntry)

ArcFileSystemCopy Method (ArcFileEntry, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Creates a copy of source inside target

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Copy(
    ArcFileEntry source,
    ArcDirectoryEntry target
)

Parameters

source
Type: CM3D2.Toolkit.Arc.EntryArcFileEntry
Source File
target
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Copy Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateDirectory Method

ArcFileSystemCreateDirectory Method

Overload List
 | Name | Description
Public method | CreateDirectory(String) | Creates a Directory with the specified name inside Root
Public method | CreateDirectory(String, ArcDirectoryEntry) | Creates a Directory with the specified name inside parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateDirectory Method (String)

ArcFileSystemCreateDirectory Method (String)

[This is preliminary documentation and is subject to change.]

Creates a Directory with the specified name inside Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcDirectoryEntry CreateDirectory(
    string name
)

Parameters

name
Type: SystemString
Directory Name

Return Value

Type: ArcDirectoryEntry
The created Directory
See Also

Reference

ArcFileSystem Class
CreateDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateDirectory Method (String, ArcDirectoryEntry)

ArcFileSystemCreateDirectory Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Creates a Directory with the specified name inside parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcDirectoryEntry CreateDirectory(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
Directory Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: ArcDirectoryEntry
The created Directory
See Also

Reference

ArcFileSystem Class
CreateDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateFile Method

ArcFileSystemCreateFile Method

Overload List
 | Name | Description
Public method | CreateFile(String) | Creates a File with the specified name inside Root
Public method | CreateFile(String, ArcDirectoryEntry) | Creates a File with the specified name inside parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateFile Method (String)

ArcFileSystemCreateFile Method (String)

[This is preliminary documentation and is subject to change.]

Creates a File with the specified name inside Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileEntry CreateFile(
    string name
)

Parameters

name
Type: SystemString
File Name

Return Value

Type: ArcFileEntry
The created File
See Also

Reference

ArcFileSystem Class
CreateFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.CreateFile Method (String, ArcDirectoryEntry)

ArcFileSystemCreateFile Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Creates a File with the specified name inside parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileEntry CreateFile(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
File Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: ArcFileEntry
The created File
See Also

Reference

ArcFileSystem Class
CreateFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Delete Method

ArcFileSystemDelete Method

Overload List
 | Name | Description
Public method | Delete(ArcFileEntry) | Deletes a File
Public method | Delete(ArcDirectoryEntry, Boolean) | Deletes a Directory
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Delete Method (ArcFileEntry)

ArcFileSystemDelete Method (ArcFileEntry)

[This is preliminary documentation and is subject to change.]

Deletes a File

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Delete(
    ArcFileEntry entry
)

Parameters

entry
Type: CM3D2.Toolkit.Arc.EntryArcFileEntry
File to Delete

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Delete Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Delete Method (ArcDirectoryEntry, Boolean)

ArcFileSystemDelete Method (ArcDirectoryEntry, Boolean)

[This is preliminary documentation and is subject to change.]

Deletes a Directory

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Delete(
    ArcDirectoryEntry entry,
    bool recursive
)

Parameters

entry
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Directory to Delete
recursive
Type: SystemBoolean
True to Delete Files and Subdirectories

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Delete Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.DetectMagic Method

ArcFileSystemDetectMagic Method

Detects if the ARC Magic Identifier is present the specified file

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static bool DetectMagic(
    string file
)

Parameters

file
Type: SystemString
File to Check

Return Value

Type: Boolean
True if ARC Magic ID detected
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.DirectoryExists Method

ArcFileSystemDirectoryExists Method

Overload List
 | Name | Description
Public method | DirectoryExists(String) | Checks if a Directory Exists inside of Root
Public method | DirectoryExists(String, ArcDirectoryEntry) | Checks if a Directory Exists inside of parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.DirectoryExists Method (String)

ArcFileSystemDirectoryExists Method (String)

[This is preliminary documentation and is subject to change.]

Checks if a Directory Exists inside of Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool DirectoryExists(
    string name
)

Parameters

name
Type: SystemString
Directory Name

Return Value

Type: Boolean
True if Exists
See Also

Reference

ArcFileSystem Class
DirectoryExists Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.DirectoryExists Method (String, ArcDirectoryEntry)

ArcFileSystemDirectoryExists Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Checks if a Directory Exists inside of parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool DirectoryExists(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
Directory Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: Boolean
True if Exists
See Also

Reference

ArcFileSystem Class
DirectoryExists Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.FileExists Method

ArcFileSystemFileExists Method

Overload List
 | Name | Description
Public method | FileExists(String) | Checks if a File Exists inside of Root
Public method | FileExists(String, ArcDirectoryEntry) | Checks if a File Exists inside of parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.FileExists Method (String)

ArcFileSystemFileExists Method (String)

[This is preliminary documentation and is subject to change.]

Checks if a File Exists inside of Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool FileExists(
    string name
)

Parameters

name
Type: SystemString
File Name

Return Value

Type: Boolean
True if Exists
See Also

Reference

ArcFileSystem Class
FileExists Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.FileExists Method (String, ArcDirectoryEntry)

ArcFileSystemFileExists Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Checks if a File Exists inside of parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool FileExists(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
File Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: Boolean
True if Exists
See Also

Reference

ArcFileSystem Class
FileExists Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetDirectory Method

ArcFileSystemGetDirectory Method

Overload List
 | Name | Description
Public method | GetDirectory(String) | Finds a Existing Directory inside Root
Public method | GetDirectory(String, ArcDirectoryEntry) | Finds a Existing Directory inside parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetDirectory Method (String)

ArcFileSystemGetDirectory Method (String)

[This is preliminary documentation and is subject to change.]

Finds a Existing Directory inside Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcDirectoryEntry GetDirectory(
    string name
)

Parameters

name
Type: SystemString
Directory Name

Return Value

Type: ArcDirectoryEntry
The Directory or null if none found
See Also

Reference

ArcFileSystem Class
GetDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetDirectory Method (String, ArcDirectoryEntry)

ArcFileSystemGetDirectory Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Finds a Existing Directory inside parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcDirectoryEntry GetDirectory(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
Directory Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: ArcDirectoryEntry
The Directory or null if none found
See Also

Reference

ArcFileSystem Class
GetDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetFile Method

ArcFileSystemGetFile Method

Overload List
 | Name | Description
Public method | GetFile(String) | Finds a Existing File inside Root
Public method | GetFile(String, ArcDirectoryEntry) | Finds a Existing File inside parent
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetFile Method (String)

ArcFileSystemGetFile Method (String)

[This is preliminary documentation and is subject to change.]

Finds a Existing File inside Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileEntry GetFile(
    string name
)

Parameters

name
Type: SystemString
File Name

Return Value

Type: ArcFileEntry
The Directory or null if none found
See Also

Reference

ArcFileSystem Class
GetFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.GetFile Method (String, ArcDirectoryEntry)

ArcFileSystemGetFile Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Finds a Existing File inside parent

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileEntry GetFile(
    string name,
    ArcDirectoryEntry parent
)

Parameters

name
Type: SystemString
File Name
parent
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: ArcFileEntry
The Directory or null if none found
See Also

Reference

ArcFileSystem Class
GetFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.HasEntry Method

ArcFileSystemHasEntry Method

Checks if an Arc Entry is part of this File System

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool HasEntry(
    ArcEntryBase a
)

Parameters

a
Type: CM3D2.Toolkit.Arc.EntryArcEntryBase
Entry A

Return Value

Type: Boolean
True if Same FileSystem
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadArc Method

ArcFileSystemLoadArc Method

Overload List
 | Name | Description
Public method | LoadArc(String) | Loads an Arc File into Root
Public method | LoadArc(String, ArcDirectoryEntry) | Loads an Arc File in this Instance into parentDir
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadArc Method (String)

ArcFileSystemLoadArc Method (String)

[This is preliminary documentation and is subject to change.]

Loads an Arc File into Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadArc(
    string arcFile
)

Parameters

arcFile
Type: SystemString
Arc File Path

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadArc Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadArc Method (String, ArcDirectoryEntry)

ArcFileSystemLoadArc Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Loads an Arc File in this Instance into parentDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadArc(
    string arcFile,
    ArcDirectoryEntry parentDir
)

Parameters

arcFile
Type: SystemString
Arc File Path
parentDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadArc Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadDirectory Method

ArcFileSystemLoadDirectory Method

Overload List
 | Name | Description
Public method | LoadDirectory(String) | Loads a Directory and its all files recursively into Root
Public method | LoadDirectory(String, ArcDirectoryEntry) | Loads a Directory and all its files recursively into parentDir
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadDirectory Method (String)

ArcFileSystemLoadDirectory Method (String)

[This is preliminary documentation and is subject to change.]

Loads a Directory and its all files recursively into Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadDirectory(
    string path
)

Parameters

path
Type: SystemString
File Path

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadDirectory Method (String, ArcDirectoryEntry)

ArcFileSystemLoadDirectory Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Loads a Directory and all its files recursively into parentDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadDirectory(
    string path,
    ArcDirectoryEntry parentDir
)

Parameters

path
Type: SystemString
File Path
parentDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadDirectory Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadFile Method

ArcFileSystemLoadFile Method

Overload List
 | Name | Description
Public method | LoadFile(String) | Loads a Single File into Root
Public method | LoadFile(String, ArcDirectoryEntry) | Loads a Single File into parentDir
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadFile Method (String)

ArcFileSystemLoadFile Method (String)

[This is preliminary documentation and is subject to change.]

Loads a Single File into Root

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadFile(
    string path
)

Parameters

path
Type: SystemString
File Path

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.LoadFile Method (String, ArcDirectoryEntry)

ArcFileSystemLoadFile Method (String, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Loads a Single File into parentDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool LoadFile(
    string path,
    ArcDirectoryEntry parentDir
)

Parameters

path
Type: SystemString
File Path
parentDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Parent Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
LoadFile Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.MergeCopy Method

ArcFileSystemMergeCopy Method

Merges a Copy of sourceDir with targetDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool MergeCopy(
    ArcDirectoryEntry sourceDir,
    ArcDirectoryEntry targetDir
)

Parameters

sourceDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Source Directory
targetDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.MergeMove Method

ArcFileSystemMergeMove Method

Merges sourceDir with targetDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool MergeMove(
    ArcDirectoryEntry sourceDir,
    ArcDirectoryEntry targetDir
)

Parameters

sourceDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Source Directory
targetDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Move Method

ArcFileSystemMove Method

Overload List
 | Name | Description
Public method | Move(ArcDirectoryEntry, ArcDirectoryEntry) | Moves into targetDir
Public method | Move(ArcFileEntry, ArcDirectoryEntry) | Moves into targetDir
Top
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Move Method (ArcDirectoryEntry, ArcDirectoryEntry)

ArcFileSystemMove Method (ArcDirectoryEntry, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Moves into targetDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Move(
    ArcDirectoryEntry sourceDir,
    ArcDirectoryEntry targetDir
)

Parameters

sourceDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Source Directory
targetDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Move Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Move Method (ArcFileEntry, ArcDirectoryEntry)

ArcFileSystemMove Method (ArcFileEntry, ArcDirectoryEntry)

[This is preliminary documentation and is subject to change.]

Moves into targetDir

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Move(
    ArcFileEntry sourceFile,
    ArcDirectoryEntry targetDir
)

Parameters

sourceFile
Type: CM3D2.Toolkit.Arc.EntryArcFileEntry
Source File
targetDir
Type: CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
Target Directory

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
Move Overload
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Rename Method

ArcFileSystemRename Method

Renames a ArcEntryBase

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Rename(
    ArcEntryBase entry,
    string newName
)

Parameters

entry
Type: CM3D2.Toolkit.Arc.EntryArcEntryBase
Entry to Rename
newName
Type: SystemString
New Name

Return Value

Type: Boolean
True
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


ArcFileSystem.Save Method

ArcFileSystemSave Method

Writes this File System instance to the Stream given by stream

Namespace: CM3D2.Toolkit.Arc
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool Save(
    Stream stream
)

Parameters

stream
Type: System.IOStream
Stream

Return Value

Type: Boolean
True if Successful
See Also

Reference

ArcFileSystem Class
CM3D2.Toolkit.Arc Namespace


CM3D2.Toolkit.Arc.Entry Namespace

CM3D2.Toolkit.Arc.Entry Namespace

The CM3D2.Toolkit.Arc.Entry namespace contains classes for holding the File and Directory Entries on a ArcFileSystem
Classes
 | Class | Description
Public class | ArcDirectoryEntry | Arc Directory Entry
Public class | ArcEntryBase | Base class for Arc File System Entries
Public class | ArcFileEntry | Arc File Entry


ArcDirectoryEntry Class

ArcDirectoryEntry Class

Arc Directory Entry
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.EntryArcEntryBase
CM3D2.Toolkit.Arc.EntryArcDirectoryEntry

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class ArcDirectoryEntry : ArcEntryBase

The ArcDirectoryEntry type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree (Inherited from ArcEntryBase.)
Public property | Directories | List of Sub Directories
Public property | DirectoryCount | Directory Count
Public property | FileCount | File Count
Public property | Files | List of Files
Public property | FileSystem | ArcFileSystem containing this Entry (Inherited from ArcEntryBase.)
Public property | FullName | Full Name of this Entry (Parents and Self) (Inherited from ArcEntryBase.)
Public property | IsRoot | Is the Root of a ArcFileSystem
Public property | Name | Name of this Entry (Inherited from ArcEntryBase.)
Public property | Parent | Parent ArcEntryBase on the File System Tree (Inherited from ArcEntryBase.)
Top
Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from ArcEntryBase.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry Properties

ArcDirectoryEntry Properties

The ArcDirectoryEntry type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree (Inherited from ArcEntryBase.)
Public property | Directories | List of Sub Directories
Public property | DirectoryCount | Directory Count
Public property | FileCount | File Count
Public property | Files | List of Files
Public property | FileSystem | ArcFileSystem containing this Entry (Inherited from ArcEntryBase.)
Public property | FullName | Full Name of this Entry (Parents and Self) (Inherited from ArcEntryBase.)
Public property | IsRoot | Is the Root of a ArcFileSystem
Public property | Name | Name of this Entry (Inherited from ArcEntryBase.)
Public property | Parent | Parent ArcEntryBase on the File System Tree (Inherited from ArcEntryBase.)
Top
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry.Directories Property

ArcDirectoryEntryDirectories Property

List of Sub Directories

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IEnumerable<ArcDirectoryEntry> Directories { get; }

Property Value

Type: IEnumerable ArcDirectoryEntry
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry.DirectoryCount Property

ArcDirectoryEntryDirectoryCount Property

Directory Count

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int DirectoryCount { get; }

Property Value

Type: Int32
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry.FileCount Property

ArcDirectoryEntryFileCount Property

File Count

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int FileCount { get; }

Property Value

Type: Int32
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry.Files Property

ArcDirectoryEntryFiles Property

List of Files

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IEnumerable<ArcFileEntry> Files { get; }

Property Value

Type: IEnumerable ArcFileEntry
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry.IsRoot Property

ArcDirectoryEntryIsRoot Property

Is the Root of a ArcFileSystem

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsRoot { get; }

Property Value

Type: Boolean
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcDirectoryEntry Methods

ArcDirectoryEntry Methods

The ArcDirectoryEntry type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from ArcEntryBase.)
Top
See Also

Reference

ArcDirectoryEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase Class

ArcEntryBase Class

Base class for Arc File System Entries
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.EntryArcEntryBase
CM3D2.Toolkit.Arc.EntryArcDirectoryEntry
CM3D2.Toolkit.Arc.EntryArcFileEntry

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract class ArcEntryBase

The ArcEntryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ArcEntryBase | Creates a new Entry, pertaining to fileSystem
Top
Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree
Public property | FileSystem | ArcFileSystem containing this Entry
Public property | FullName | Full Name of this Entry (Parents and Self)
Public property | Name | Name of this Entry
Public property | Parent | Parent ArcEntryBase on the File System Tree
Top
Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase Constructor

ArcEntryBase Constructor

Creates a new Entry, pertaining to fileSystem

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected ArcEntryBase(
    ArcFileSystem fileSystem
)

Parameters

fileSystem
Type: CM3D2.Toolkit.ArcArcFileSystem
File System
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase Properties

ArcEntryBase Properties

The ArcEntryBase type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree
Public property | FileSystem | ArcFileSystem containing this Entry
Public property | FullName | Full Name of this Entry (Parents and Self)
Public property | Name | Name of this Entry
Public property | Parent | Parent ArcEntryBase on the File System Tree
Top
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.Depth Property

ArcEntryBaseDepth Property

Entry Depth in the ArcFileSystem Tree

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Depth { get; }

Property Value

Type: Int32
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.FileSystem Property

ArcEntryBaseFileSystem Property

ArcFileSystem containing this Entry

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcFileSystem FileSystem { get; }

Property Value

Type: ArcFileSystem
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.FullName Property

ArcEntryBaseFullName Property

Full Name of this Entry (Parents and Self)

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string FullName { get; }

Property Value

Type: String
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.Name Property

ArcEntryBaseName Property

Name of this Entry

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.Parent Property

ArcEntryBaseParent Property

Parent ArcEntryBase on the File System Tree

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ArcEntryBase Parent { get; }

Property Value

Type: ArcEntryBase
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase Methods

ArcEntryBase Methods

The ArcEntryBase type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcEntryBase.ToString Method

ArcEntryBaseToString Method

Returns a string that represents the current object.

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
A string that represents the current object.
See Also

Reference

ArcEntryBase Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcFileEntry Class

ArcFileEntry Class

Arc File Entry
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.EntryArcEntryBase
CM3D2.Toolkit.Arc.EntryArcFileEntry

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class ArcFileEntry : ArcEntryBase

The ArcFileEntry type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree (Inherited from ArcEntryBase.)
Public property | FileSystem | ArcFileSystem containing this Entry (Inherited from ArcEntryBase.)
Public property | FullName | Full Name of this Entry (Parents and Self) (Inherited from ArcEntryBase.)
Public property | Name | Name of this Entry (Inherited from ArcEntryBase.)
Public property | Parent | Parent ArcEntryBase on the File System Tree (Inherited from ArcEntryBase.)
Public property | Pointer | File Pointer, Contains File Size and Data
Top
Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from ArcEntryBase.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.Entry Namespace


ArcFileEntry Properties

ArcFileEntry Properties

The ArcFileEntry type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Entry Depth in the ArcFileSystem Tree (Inherited from ArcEntryBase.)
Public property | FileSystem | ArcFileSystem containing this Entry (Inherited from ArcEntryBase.)
Public property | FullName | Full Name of this Entry (Parents and Self) (Inherited from ArcEntryBase.)
Public property | Name | Name of this Entry (Inherited from ArcEntryBase.)
Public property | Parent | Parent ArcEntryBase on the File System Tree (Inherited from ArcEntryBase.)
Public property | Pointer | File Pointer, Contains File Size and Data
Top
See Also

Reference

ArcFileEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcFileEntry.Pointer Property

ArcFileEntryPointer Property

File Pointer, Contains File Size and Data

Namespace: CM3D2.Toolkit.Arc.Entry
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public FilePointerBase Pointer { get; set; }

Property Value

Type: FilePointerBase
See Also

Reference

ArcFileEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


ArcFileEntry Methods

ArcFileEntry Methods

The ArcFileEntry type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from ArcEntryBase.)
Top
See Also

Reference

ArcFileEntry Class
CM3D2.Toolkit.Arc.Entry Namespace


CM3D2.Toolkit.Arc.FilePointer Namespace

CM3D2.Toolkit.Arc.FilePointer Namespace

The CM3D2.Toolkit.Arc.FilePointer namespace contains classes for holding Pointers and File Data on a ArcFileSystem
Classes
 | Class | Description
Public class | ArcFilePointer | A Arc-File File Pointer Holds a reference to a File inside an Arc File
Public class | FilePointerBase | Base Class for all File Pointers
Public class | MemoryFilePointer | A In-Memory File Pointer Holds the Data for a File in Memory
Public class | NullFilePointer | A Null, Zero-Byte File Pointer
Public class | WindowsFilePointer | A Local Disk File Pointer Holds a reference to a Local File on the Underlying Operating System


ArcFilePointer Class

ArcFilePointer Class

A Arc-File File Pointer

Holds a reference to a File inside an Arc File

Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.FilePointerFilePointerBase
CM3D2.Toolkit.Arc.FilePointerArcFilePointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class ArcFilePointer : FilePointerBase

The ArcFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer Properties

ArcFilePointer Properties

The ArcFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer.Compressed Property

ArcFilePointerCompressed Property

File Data is Compressed

See Deflate.

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Compressed { get; }

Property Value

Type: Boolean
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer.Data Property

ArcFilePointerData Property

File Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer.RawSize Property

ArcFilePointerRawSize Property

Decompressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint RawSize { get; }

Property Value

Type: UInt32
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer.Size Property

ArcFilePointerSize Property

Compressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint Size { get; }

Property Value

Type: UInt32
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer Methods

ArcFilePointer Methods

The ArcFilePointer type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


ArcFilePointer.Dispose Method

ArcFilePointerDispose Method

Disposes of Used Resources

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override void Dispose()

Implements

IDisposableDispose
See Also

Reference

ArcFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase Class

FilePointerBase Class

Base Class for all File Pointers
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.FilePointerFilePointerBase
CM3D2.Toolkit.Arc.FilePointerArcFilePointer
CM3D2.Toolkit.Arc.FilePointerMemoryFilePointer
CM3D2.Toolkit.Arc.FilePointerNullFilePointer
CM3D2.Toolkit.Arc.FilePointerWindowsFilePointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract class FilePointerBase : IDisposable

The FilePointerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FilePointerBase | Initializes a new instance of the FilePointerBase class
Top
Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate.
Public property | Data | File Data
Public property | RawSize | Decompressed Size
Public property | Size | Compressed Size
Top
Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer
Public method | Decompress | Decompresses this File Pointer
Public method | Dispose | Disposes of Used Resources
Top
See Also

Reference

CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase Constructor

FilePointerBase Constructor

Initializes a new instance of the FilePointerBase class

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected FilePointerBase()
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase Properties

FilePointerBase Properties

The FilePointerBase type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate.
Public property | Data | File Data
Public property | RawSize | Decompressed Size
Public property | Size | Compressed Size
Top
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Compressed Property

FilePointerBaseCompressed Property

File Data is Compressed

See Deflate.

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract bool Compressed { get; }

Property Value

Type: Boolean
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Data Property

FilePointerBaseData Property

File Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.RawSize Property

FilePointerBaseRawSize Property

Decompressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract uint RawSize { get; }

Property Value

Type: UInt32
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Size Property

FilePointerBaseSize Property

Compressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public abstract uint Size { get; }

Property Value

Type: UInt32
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase Methods

FilePointerBase Methods

The FilePointerBase type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer
Public method | Decompress | Decompresses this File Pointer
Public method | Dispose | Disposes of Used Resources
Top
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Compress Method

FilePointerBaseCompress Method

Compresses this File Pointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public virtual FilePointerBase Compress()

Return Value

Type: FilePointerBase
A Compressed copy of this FilePointerBase
Remarks
Default implementation returns a MemoryFilePointer
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Decompress Method

FilePointerBaseDecompress Method

Decompresses this File Pointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public virtual FilePointerBase Decompress()

Return Value

Type: FilePointerBase
A Decompressed copy of this FilePointerBase
Remarks
Default implementation returns a MemoryFilePointer
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


FilePointerBase.Dispose Method

FilePointerBaseDispose Method

Disposes of Used Resources

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public virtual void Dispose()

Implements

IDisposableDispose
See Also

Reference

FilePointerBase Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Class

MemoryFilePointer Class

A In-Memory File Pointer

Holds the Data for a File in Memory

Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.FilePointerFilePointerBase
CM3D2.Toolkit.Arc.FilePointerMemoryFilePointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class MemoryFilePointer : FilePointerBase

The MemoryFilePointer type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryFilePointer(Byte) | Creates a new Memory File Pointer from Uncompressed Data
Public method | MemoryFilePointer(Byte, Int32) | Creates a new Memory File Pointer from Compressed Data See Deflate
Top
Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Constructor

MemoryFilePointer Constructor

Overload List
 | Name | Description
Public method | MemoryFilePointer(Byte) | Creates a new Memory File Pointer from Uncompressed Data
Public method | MemoryFilePointer(Byte, Int32) | Creates a new Memory File Pointer from Compressed Data See Deflate
Top
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Constructor (Byte[])

MemoryFilePointer Constructor (Byte)

[This is preliminary documentation and is subject to change.]

Creates a new Memory File Pointer from Uncompressed Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public MemoryFilePointer(
    byte[] data
)

Parameters

data
Type: SystemByte
Uncompressed Data
See Also

Reference

MemoryFilePointer Class
MemoryFilePointer Overload
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Constructor (Byte[], Int32)

MemoryFilePointer Constructor (Byte, Int32)

[This is preliminary documentation and is subject to change.]

Creates a new Memory File Pointer from Compressed Data

See Deflate

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public MemoryFilePointer(
    byte[] data,
    int rawSize
)

Parameters

data
Type: SystemByte
Compressed Data
rawSize
Type: SystemInt32
Decompressed Size
See Also

Reference

MemoryFilePointer Class
MemoryFilePointer Overload
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Properties

MemoryFilePointer Properties

The MemoryFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer.Compressed Property

MemoryFilePointerCompressed Property

File Data is Compressed

See Deflate.

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Compressed { get; }

Property Value

Type: Boolean
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer.Data Property

MemoryFilePointerData Property

File Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer.RawSize Property

MemoryFilePointerRawSize Property

Decompressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint RawSize { get; }

Property Value

Type: UInt32
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer.Size Property

MemoryFilePointerSize Property

Compressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint Size { get; }

Property Value

Type: UInt32
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer Methods

MemoryFilePointer Methods

The MemoryFilePointer type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


MemoryFilePointer.Dispose Method

MemoryFilePointerDispose Method

Disposes of Used Resources

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override void Dispose()

Implements

IDisposableDispose
See Also

Reference

MemoryFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer Class

NullFilePointer Class

A Null, Zero-Byte File Pointer
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.FilePointerFilePointerBase
CM3D2.Toolkit.Arc.FilePointerNullFilePointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class NullFilePointer : FilePointerBase

The NullFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
Methods
 | Name | Description
Public method | Compress | Returns the corresponding NullFilePointer, depending on Compressed (Overrides FilePointerBaseCompress.)
Public method | Decompress | Returns the corresponding NullFilePointer, depending on Compressed (Overrides FilePointerBaseDecompress.)
Public method | Dispose | Disposes of Used Resources (Inherited from FilePointerBase.)
Top
Fields
Name | Description
CompressedPointer | Static, Compressed-Tagged Null File Pointer
UncompressedPointer | Static, Uncompressed-Tagged Null File Pointer
Top
Remarks
Has no Constructors.

See CompressedPointer and UncompressedPointer

See Also

Reference

CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer Properties

NullFilePointer Properties

The NullFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.Compressed Property

NullFilePointerCompressed Property

File Data is Compressed

See Deflate.

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Compressed { get; }

Property Value

Type: Boolean
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.Data Property

NullFilePointerData Property

File Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.RawSize Property

NullFilePointerRawSize Property

Decompressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint RawSize { get; }

Property Value

Type: UInt32
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.Size Property

NullFilePointerSize Property

Compressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint Size { get; }

Property Value

Type: UInt32
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer Methods

NullFilePointer Methods

The NullFilePointer type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Returns the corresponding NullFilePointer, depending on Compressed (Overrides FilePointerBaseCompress.)
Public method | Decompress | Returns the corresponding NullFilePointer, depending on Compressed (Overrides FilePointerBaseDecompress.)
Public method | Dispose | Disposes of Used Resources (Inherited from FilePointerBase.)
Top
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.Compress Method

NullFilePointerCompress Method

Returns the corresponding NullFilePointer, depending on Compressed

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override FilePointerBase Compress()

Return Value

Type: FilePointerBase
CompressedPointer or UncompressedPointer
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.Decompress Method

NullFilePointerDecompress Method

Returns the corresponding NullFilePointer, depending on Compressed

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override FilePointerBase Decompress()

Return Value

Type: FilePointerBase
CompressedPointer or UncompressedPointer
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer Fields

NullFilePointer Fields

The NullFilePointer type exposes the following members.

Fields
Name | Description
CompressedPointer | Static, Compressed-Tagged Null File Pointer
UncompressedPointer | Static, Uncompressed-Tagged Null File Pointer
Top
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.CompressedPointer Field

NullFilePointerCompressedPointer Field

Static, Compressed-Tagged Null File Pointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static NullFilePointer CompressedPointer

Field Value

Type: NullFilePointer
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


NullFilePointer.UncompressedPointer Field

NullFilePointerUncompressedPointer Field

Static, Uncompressed-Tagged Null File Pointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static NullFilePointer UncompressedPointer

Field Value

Type: NullFilePointer
See Also

Reference

NullFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer Class

WindowsFilePointer Class

A Local Disk File Pointer

Holds a reference to a Local File on the Underlying Operating System

Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.Arc.FilePointerFilePointerBase
CM3D2.Toolkit.Arc.FilePointerWindowsFilePointer

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class WindowsFilePointer : FilePointerBase

The WindowsFilePointer type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsFilePointer | Creates a new Physical Disk File Pointer for the file given by filePath
Top
Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer Constructor

WindowsFilePointer Constructor

Creates a new Physical Disk File Pointer for the file given by filePath

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public WindowsFilePointer(
    string filePath
)

Parameters

filePath
Type: SystemString
File Path
Exceptions
Exception | Condition
ArgumentException | Thrown when the File given by filePath exceeds 4,294,967,295 bytes (4GB)
FileNotFoundException | Thrown when the File given by filePath does not exist
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer Properties

WindowsFilePointer Properties

The WindowsFilePointer type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | File Data is Compressed See Deflate. (Overrides FilePointerBaseCompressed.)
Public property | Data | File Data (Overrides FilePointerBaseData.)
Public property | RawSize | Decompressed Size (Overrides FilePointerBaseRawSize.)
Public property | Size | Compressed Size (Overrides FilePointerBaseSize.)
Top
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer.Compressed Property

WindowsFilePointerCompressed Property

File Data is Compressed

See Deflate.

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override bool Compressed { get; }

Property Value

Type: Boolean
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer.Data Property

WindowsFilePointerData Property

File Data

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override byte[] Data { get; }

Property Value

Type: Byte
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer.RawSize Property

WindowsFilePointerRawSize Property

Decompressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint RawSize { get; }

Property Value

Type: UInt32
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer.Size Property

WindowsFilePointerSize Property

Compressed Size

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override uint Size { get; }

Property Value

Type: UInt32
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer Methods

WindowsFilePointer Methods

The WindowsFilePointer type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses this File Pointer (Inherited from FilePointerBase.)
Public method | Decompress | Decompresses this File Pointer (Inherited from FilePointerBase.)
Public method | Dispose | Disposes of Used Resources (Overrides FilePointerBaseDispose.)
Top
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


WindowsFilePointer.Dispose Method

WindowsFilePointerDispose Method

Disposes of Used Resources

Namespace: CM3D2.Toolkit.Arc.FilePointer
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override void Dispose()

Implements

IDisposableDispose
See Also

Reference

WindowsFilePointer Class
CM3D2.Toolkit.Arc.FilePointer Namespace


CM3D2.Toolkit.Logging Namespace

CM3D2.Toolkit.Logging Namespace

The CM3D2.Toolkit.Logging namespace contains classes for receiving Log Messages from the Library
Classes
 | Class | Description
Public class | NullLogger | Null Logger
Interfaces
 | Interface | Description
Public interface | ILogger | Simple Logging Abstraction Layer
Enumerations
 | Enumeration | Description
Public enumeration | LogLevel | Log Level Enumerator


ILogger Interface

ILogger Interface

Simple Logging Abstraction Layer

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ILogger

The ILogger type exposes the following members.

Properties
 | Name | Description
Public property | Name | Logger Name
Top
Methods
 | Name | Description
Public method | Debug | Debug-Level Log Message
Public method | Error | Error-Level Log Message
Public method | Fatal | Fatal-Level Log Message
Public method | Info | Info-Level Log Message
Public method | Trace | Trace-Level Log Message
Public method | Warn | Warn-Level Log Message
Top
See Also

Reference

CM3D2.Toolkit.Logging Namespace


ILogger Properties

ILogger Properties

The ILogger type exposes the following members.

Properties
 | Name | Description
Public property | Name | Logger Name
Top
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Name Property

ILoggerName Property

Logger Name

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger Methods

ILogger Methods

The ILogger type exposes the following members.

Methods
 | Name | Description
Public method | Debug | Debug-Level Log Message
Public method | Error | Error-Level Log Message
Public method | Fatal | Fatal-Level Log Message
Public method | Info | Info-Level Log Message
Public method | Trace | Trace-Level Log Message
Public method | Warn | Warn-Level Log Message
Top
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Debug Method

ILoggerDebug Method

Debug-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Debug(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Error Method

ILoggerError Method

Error-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Error(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Fatal Method

ILoggerFatal Method

Fatal-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Fatal(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Info Method

ILoggerInfo Method

Info-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Info(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Trace Method

ILoggerTrace Method

Trace-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Trace(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


ILogger.Warn Method

ILoggerWarn Method

Warn-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Warn(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters
See Also

Reference

ILogger Interface
CM3D2.Toolkit.Logging Namespace


LogLevel Enumeration

LogLevel Enumeration

Log Level Enumerator

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum LogLevel
Members
Member name | Value | Description
Trace | 0 | Trace Level
Debug | 1 | Debug Level
Info | 2 | Information Level
Warn | 3 | Warning Level
Error | 4 | Error Level
Fatal | 5 | Fatal Level
Off | 6 | Off Level
See Also

Reference

CM3D2.Toolkit.Logging Namespace


NullLogger Class

NullLogger Class

Null Logger
Inheritance Hierarchy
SystemObject
CM3D2.Toolkit.LoggingNullLogger

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public sealed class NullLogger : ILogger

The NullLogger type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Debug | Debug-Level Log Message
Public method | Error | Error-Level Log Message
Public method | Fatal | Fatal-Level Log Message
Public method | Info | Info-Level Log Message
Public method | Trace | Trace-Level Log Message
Public method | Warn | Warn-Level Log Message
Top
Fields
Name | Description
Instance | Null Logger Instance
Top
See Also

Reference

CM3D2.Toolkit.Logging Namespace


NullLogger Properties

NullLogger Properties

The NullLogger type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Name Property

NullLoggerName Property

[Missing <summary> documentation for "P:CM3D2.Toolkit.Logging.NullLogger.Name"]

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String

Implements

ILoggerName
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger Methods

NullLogger Methods

The NullLogger type exposes the following members.

Methods
 | Name | Description
Public method | Debug | Debug-Level Log Message
Public method | Error | Error-Level Log Message
Public method | Fatal | Fatal-Level Log Message
Public method | Info | Info-Level Log Message
Public method | Trace | Trace-Level Log Message
Public method | Warn | Warn-Level Log Message
Top
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Debug Method

NullLoggerDebug Method

Debug-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Debug(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerDebug(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Error Method

NullLoggerError Method

Error-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Error(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerError(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Fatal Method

NullLoggerFatal Method

Fatal-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Fatal(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerFatal(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Info Method

NullLoggerInfo Method

Info-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Info(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerInfo(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Trace Method

NullLoggerTrace Method

Trace-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Trace(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerTrace(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Warn Method

NullLoggerWarn Method

Warn-Level Log Message

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public void Warn(
    string message,
    params Object[] args
)

Parameters

message
Type: SystemString
Message
args
Type: SystemObject
Parameters

Implements

ILoggerWarn(String, Object)
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger Fields

NullLogger Fields

The NullLogger type exposes the following members.

Fields
Name | Description
Instance | Null Logger Instance
Top
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


NullLogger.Instance Field

NullLoggerInstance Field

Null Logger Instance

Namespace: CM3D2.Toolkit.Logging
Assembly: CM3D2.Toolkit (in CM3D2.Toolkit.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static NullLogger Instance

Field Value

Type: NullLogger
See Also

Reference

NullLogger Class
CM3D2.Toolkit.Logging Namespace


Version History

Version History

The topics in this section describe the various changes made to CM3D2 Toolkit over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0.0


Version 1.0.0.0

Version 1.0.0.0

Version 1.0.0.0 was released on Dec [TODO]th 2015.

Changes in This Release

  • Initial Release

See Also

Other Resources

Version History