yaleh commited on
Commit
4e322ec
·
1 Parent(s): 6c4154c

Commented out Streamlit app.

Browse files
Files changed (1) hide show
  1. Dockerfile +17 -17
Dockerfile CHANGED
@@ -23,26 +23,26 @@ EXPOSE 7860
23
  # Run the script when the container launches
24
  CMD python app/gradio_meta_prompt.py
25
 
26
- # streamlit
27
- FROM python:3.10 as streamlit
28
 
29
- # Set the working directory in the container
30
- WORKDIR /app
31
- RUN pip install --no-cache-dir -U poetry
32
 
33
- # Copy all files from the current directory to the working directory in the container
34
- COPY config.yml poetry.lock pyproject.toml /app/
35
 
36
- RUN poetry config virtualenvs.create false
37
- RUN poetry install --with=dev
38
 
39
- COPY meta_prompt /app/meta_prompt/
40
- COPY app /app/app/
41
- # COPY app.py /app/app.py
42
- RUN poetry install --with=dev
43
 
44
- # Expose the Streamlit default port
45
- EXPOSE 8501
46
 
47
- # Run the Streamlit script when the container launches
48
- CMD ["streamlit", "run", "app/streamlit_tab_app.py"]
 
23
  # Run the script when the container launches
24
  CMD python app/gradio_meta_prompt.py
25
 
26
+ # # streamlit
27
+ # FROM python:3.10 as streamlit
28
 
29
+ # # Set the working directory in the container
30
+ # WORKDIR /app
31
+ # RUN pip install --no-cache-dir -U poetry
32
 
33
+ # # Copy all files from the current directory to the working directory in the container
34
+ # COPY config.yml poetry.lock pyproject.toml /app/
35
 
36
+ # RUN poetry config virtualenvs.create false
37
+ # RUN poetry install --with=dev
38
 
39
+ # COPY meta_prompt /app/meta_prompt/
40
+ # COPY app /app/app/
41
+ # # COPY app.py /app/app.py
42
+ # RUN poetry install --with=dev
43
 
44
+ # # Expose the Streamlit default port
45
+ # EXPOSE 8501
46
 
47
+ # # Run the Streamlit script when the container launches
48
+ # CMD ["streamlit", "run", "app/streamlit_tab_app.py"]